[ejabberd] ejabberd won't start - how to debug?

Andy Theuninck gohanman at gmail.com
Sat Feb 4 04:38:00 MSK 2012


Same thing. It doesn't matter at all what arguments (or none) I run
ejabberdctl with. No output, no logging, nothing.

Assuming redhat's ejabberdctl binary is doing roughly the same thing
as the ejabberdctl.template shell script in the 2.1.8 source, I think
the problem is actually in their erlang files. erl crashes immediately
with an Illegal Instruction error.

On Fri, Feb 3, 2012 at 5:29 PM, Jorge Guntanis <guntanis at gmail.com> wrote:
> Try running ejabberdctl live.
>
>
>
> On Feb 3, 2012, at 12:06 PM, Andy Theuninck <gohanman at gmail.com> wrote:
>
>> I'm trying to migrate ejabberd to a new server (CentOS 6). I installed
>> ejabberd 2.1.8 from OS-provided binaries. I then copied
>> /etc/ejabberd/ejabberd.cfg and /etc/ejabberd/ejabberdctl.cfg from my
>> working server (also CentOS, also 2.1.8) to the new server. When I try
>> to start ejabberd via the init script, nothing happens.
>>
>> Digging into the script, the command it's actually running for "start" is this:
>> ejabberdctl start --config /etc/ejabberd/ejabberd.cfg --ctl-config
>> /etc/ejabberd/ejabberdctl.cfg --logs /var/log/ejabberd/ --spool
>> /var/lib/ejabberd/spool
>>
>> Running it myself, as root, produces no output, writes nothing to the
>> specified log directory, and does not start ejabberd. Is there any way
>> to coax more debug information out of ejabberdctl? I'm at a loss how
>> to find the problem without at least some kind of feedback.
>> _______________________________________________
>> ejabberd mailing list
>> ejabberd at jabber.ru
>> http://lists.jabber.ru/mailman/listinfo/ejabberd
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd


More information about the ejabberd mailing list