[ejabberd] ejabberd won't start

Hanns Mattes hanns at hannsmattes.de
Thu Jan 5 18:45:46 MSK 2012


Hi, 

just for the records: 

Hanns Mattes <hanns at hannsmattes.de> schrieb:

>Am 17.12.2011 01:29, schrieb Badlop:
>> 2011/12/16 Hanns Mattes <hanns at hannsmattes.de>:
>>> Packages are erlang R15B-2.1 and ejabberd 2.1.8-1.5
>> 
>> Those two are incompatible.
>> You have three solutions:
>> A) download ejabberd 2.1.x from Git,
>> B) or apply three patches to the 2.1.8 source code (ask me for patches)
>> C) or get erlang R14
>> ejabberd 2.1.10 will support Erlang R15B, but it isn't yet ready to be released.

As Badlop stated: Waiting for 21.1.10 did the trick. I had to compile it
myself, because Opensuse is still with incompatible 2.1.8, but that
wasn't much of a problem.

Once again: Thanks for the help.

Regards Hanns


More information about the ejabberd mailing list