[ejabberd] Returning to ejabberd after trying openfire

Sylvain Niles sylvain.niles at gmail.com
Sat Nov 10 16:26:07 MSK 2012


For the TLS error it looks like it can't find your SSL cert on your
ejabberd server.

http://www.ejabberd.im/tuto-install-ejabberd

Section 4 covers configuring it and pointing it to the right file. If you
already have done that I'd check permissions on the file.

-Sylvain


On Sat, Nov 10, 2012 at 4:21 AM, Phil Reynolds <
phil-jabber at tinsleyviaduct.com> wrote:

> Well, I've installed ejabberd, but I can't get any clients connected.
>
> If I try to get my asterisk server to connect as a client, with no TLS
> or SASL, I get repeated connections that do nothing:
>
> =INFO REPORT==== 2012-11-10 12:11:41 ===
> I(<0.347.0>:ejabberd_listener:281) : (#Port<0.3341>) Accepted
> connection {{127,0,0,1},51087} -> {{127,0,0,1},5222}
>
> =INFO REPORT==== 2012-11-10 12:12:35 ===
> I(<0.347.0>:ejabberd_listener:281) : (#Port<0.3343>) Accepted
> connection {{127,0,0,1},51088} -> {{127,0,0,1},5222}
>
> =INFO REPORT==== 2012-11-10 12:13:29 ===
> I(<0.347.0>:ejabberd_listener:281) : (#Port<0.3345>) Accepted
> connection {{127,0,0,1},51089} -> {{127,0,0,1},5222}
>
> =INFO REPORT==== 2012-11-10 12:14:23 ===
> I(<0.347.0>:ejabberd_listener:281) : (#Port<0.3347>) Accepted
> connection {{127,0,0,1},51090} -> {{127,0,0,1},5222}
>
> SASL enabled does this:
>
> =INFO REPORT==== 2012-11-10 12:15:27 ===
> I(<0.347.0>:ejabberd_listener:281) : (#Port<0.3349>) Accepted
> connection {{127,0,0,1},51091} -> {{127,0,0,1},5222}
>
> =INFO REPORT==== 2012-11-10 12:15:31 ===
> I(<0.576.0>:ejabberd_c2s:767) :
> ({socket_state,gen_tcp,#Port<0.3349>,<0.575.0>}) Accepted
> authentication for asterisk by ejabberd_auth_internal
>
> =INFO REPORT==== 2012-11-10 12:15:31 ===
> I(<0.576.0>:ejabberd_c2s:938) :
> ({socket_state,gen_tcp,#Port<0.3349>,<0.575.0>}) Opened session for
> asterisk at firthpark.tinsleyviaduct.com/asterisk
>
> =INFO REPORT==== 2012-11-10 12:15:31 ===
> I(<0.576.0>:ejabberd_c2s:1502) :
> ({socket_state,gen_tcp,#Port<0.3349>,<0.575.0>}) Close session for
> asterisk at firthpark.tinsleyviaduct.com/asterisk
>
> ... crashing asterisk.
>
> TLS enabled does this:
>
> =INFO REPORT==== 2012-11-10 12:20:14 ===
> I(<0.347.0>:ejabberd_listener:281) : (#Port<0.3508>) Accepted
> connection {{127,0,0,1},51139} -> {{127,0,0,1},5222}
>
> =ERROR REPORT==== 2012-11-10 12:20:18 ===
> ** State machine <0.686.0> terminating
> ** Last event in was {xmlstreamelement,
>                          {xmlelement,"starttls",
>                              [{"xmlns","urn:ietf:params:xml:ns:xmpp-tls"}],
>                              []}}
> ** When State == wait_for_feature_request
> **      Data  == {state,{socket_state,gen_tcp,#Port<0.3508>,<0.685.0>},
>
> ejabberd_socket,#Ref<0.0.0.11871>,false,"429670400",
>                         {sasl_state,"jabber","firthpark.tinsleyviaduct.com
> ",
>                                     [],#Fun<ejabberd_c2s.1.124955785>,
>                                     #Fun<ejabberd_c2s.2.124955785>,
>                                     #Fun<ejabberd_c2s.3.124955785
> >,undefined,
>                                     undefined},
>                         c2s,c2s_shaper,false,true,false,false,
>                         [verify_none,{certfile,"/etc/ejabberd/tvc.pem"}],
>                         false,undefined,[],"firthpark.tinsleyviaduct.com
> ",[],
>                         undefined,
>                         {pres_t,0},
>                         {pres_f,0},
>                         {pres_a,0},
>                         {pres_i,0},
>                         undefined,undefined,undefined,false,
>                         {userlist,none,[],false},
>                         unknown,unknown,
>                         {{127,0,0,1},51139},
>                         [],[]}
> ** Reason for termination =
> ** {{badmatch,{error,"SSL_CTX_use_PrivateKey_file failed:
> error:0906D06C:PEM routines:PEM_read_bio:no start line"}},
> [{ejabberd_socket,starttls,3,[{file,"ejabberd_socket.erl"},{line,143}]},
> {ejabberd_c2s,wait_for_feature_request,2,
> [{file,"ejabberd_c2s.erl"},{line,679}]},
> {p1_fsm,handle_msg,10,[{file,"p1_fsm.erl"},{line,544}]},
> {proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,227}]}]}
>
> =INFO REPORT==== 2012-11-10 12:20:18 ===
> I(<0.347.0>:ejabberd_listener:281) : (#Port<0.3511>) Accepted
> connection {{127,0,0,1},51140} -> {{127,0,0,1},5222}
>
> =ERROR REPORT==== 2012-11-10 12:20:22 ===
> ** State machine <0.688.0> terminating
> ** Last event in was {xmlstreamelement,
>                          {xmlelement,"starttls",
>                              [{"xmlns","urn:ietf:params:xml:ns:xmpp-tls"}],
>                              []}}
> ** When State == wait_for_feature_request
> **      Data  == {state,{socket_state,gen_tcp,#Port<0.3511>,<0.687.0>},
>
> ejabberd_socket,#Ref<0.0.0.11880>,false,"569045980",
>                         {sasl_state,"jabber","firthpark.tinsleyviaduct.com
> ",
>                                     [],#Fun<ejabberd_c2s.1.124955785>,
>                                     #Fun<ejabberd_c2s.2.124955785>,
>                                     #Fun<ejabberd_c2s.3.124955785
> >,undefined,
>                                     undefined},
>                         c2s,c2s_shaper,false,true,false,false,
>                         [verify_none,{certfile,"/etc/ejabberd/tvc.pem"}],
>                         false,undefined,[],"firthpark.tinsleyviaduct.com
> ",[],
>                         undefined,
>                         {pres_t,0},
>                         {pres_f,0},
>                         {pres_a,0},
>                         {pres_i,0},
>                         undefined,undefined,undefined,false,
>                         {userlist,none,[],false},
>                         unknown,unknown,
>                         {{127,0,0,1},51140},
>                         [],[]}
> ** Reason for termination =
> ** {{badmatch,{error,"SSL_CTX_use_PrivateKey_file failed:
> error:0906D06C:PEM routines:PEM_read_bio:no start line"}},
> [{ejabberd_socket,starttls,3,[{file,"ejabberd_socket.erl"},{line,143}]},
> {ejabberd_c2s,wait_for_feature_request,2,
> [{file,"ejabberd_c2s.erl"},{line,679}]},
> {p1_fsm,handle_msg,10,[{file,"p1_fsm.erl"},{line,544}]},
> {proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,227}]}]}
>
> Similar problems are affecting other clients.
>
> What do I do to fix this?
>
> --
> Phil Reynolds
> mail: phil-jabber at tinsleyviaduct.com
> Web: http://phil.tinsleyviaduct.com/
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20121110/397b914b/attachment.html>


More information about the ejabberd mailing list