[ejabberd] Problem configuring ejabberd on ubuntu ami of amazon ec2

andy nes andynes83 at gmail.com
Tue Nov 20 13:27:07 MSK 2012


Hi Anurag,

I first installed ejabberd (2.1.10) on my local machine (running on ubuntu
12.04) using apt-get. I could set it up OK. Web interface was fine.

Next, I replicated that and installed the same version of ejabberd (2.1.10)
on Amazon EC2 instance running on ubuntu 12.04 64 bit. But here the web
interface has the issue.

Do you think I still need to install the setup file from the process one
website?

/andy


On Tue, Nov 20, 2012 at 2:48 PM, Anurag Srivastava <anurag.cs at gmail.com>wrote:

> Hello Andy,
>
> Get the setup file from http://www.process-one.net/en/ejabberd/downloads/and install on your system.
>
> You also need to update ejabberd.cfg file as per your requirement.
>
> Regards,
> Anurag
>
>
> On Tue, Nov 20, 2012 at 9:14 AM, andy nes <andynes83 at gmail.com> wrote:
>
>> Got it. The version is 2.1.10-2ubuntu1
>>
>> regarding ejabberd.config file, I haven't changed anything. Just added
>> admin user and host. here are the changes
>>
>> %% Admin user
>> {acl, admin, {user, "admin", "dev.example.com"}}.
>>
>> %% Hostname
>> {hosts, ["localhost", "myhostname", "dev.example.com"]}.
>>
>>  /andy
>>
>>
>> On Tue, Nov 20, 2012 at 2:14 PM, andy nes <andynes83 at gmail.com> wrote:
>>
>>> I did apt-get. How to know which version I have installed?
>>>
>>> /andy
>>>
>>>
>>> On Tue, Nov 20, 2012 at 2:06 PM, Evgeniy Khramtsov <xramtsov at gmail.com>wrote:
>>>
>>>>  On 20.11.2012 18:29, andy nes wrote:
>>>>
>>>> Hi,
>>>>
>>>>  This is my first experience with ejabberd. Spare me if I miss
>>>> anything.
>>>>
>>>>  I have installed ejabberd server on ubuntu 12.04 AMI on Amazon EC2.
>>>>
>>>>  I have successfully installed the server, added the admin user and
>>>> host in the config file and opened up reqd ports (5222, 5223, 5269, 5280).
>>>>
>>>>  Now I tried to login the web admin interface using the admin user id
>>>> and password. I could log in, BUT I could only see one section, Virtual
>>>> Hosts. No Control Lists, Access rules, Nodes and Statistics Menu items on
>>>> the left.
>>>> Also, when I click Virtual Hosts Menu item, the page that comes up does
>>>> not show anything.
>>>>
>>>>
>>>> What version of ejabberd are you using?
>>>>
>>>> --
>>>> Regards,
>>>> Evgeniy Khramtsov, ProcessOne.xmpp:xram at jabber.ru.
>>>>
>>>>
>>>> _______________________________________________
>>>> ejabberd mailing list
>>>> ejabberd at jabber.ru
>>>> http://lists.jabber.ru/mailman/listinfo/ejabberd
>>>>
>>>>
>>>
>>
>> _______________________________________________
>> ejabberd mailing list
>> ejabberd at jabber.ru
>> http://lists.jabber.ru/mailman/listinfo/ejabberd
>>
>>
>
>
> --
> Anurag Srivastava
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20121120/a15a9b0a/attachment-0001.html>


More information about the ejabberd mailing list