[ejabberd] mod_muc_admin and "badrecord,state" errors

Nathaniel Irons natty at bumppo.net
Wed Oct 31 22:23:11 MSK 2012


Hello,

I'm using ejabberd 2.1.10, on ubuntu 12.04.1. mod_muc_admin (r1133,
built from trunk, where it was updated recently) has a lot of
functionality that I'm looking for, but most of it just returns
errors, whether I invoke it from ejabberdctl or the web interface. For
example:

$ sudo ejabberdctl get_room_affiliations test_room conference.ourdomain.com
Problem 'error {badrecord,state}' occurred executing the command.
Stacktrace: [{mod_muc_admin,get_room_affiliations,2},
             {ejabberd_ctl,call_command,3},
             {ejabberd_ctl,try_call_command,3},
             {ejabberd_ctl,process2,3},
             {ejabberd_ctl,process,1},
             {rpc,'-handle_call_call/6-fun-0-',5}]

I get a similar "badrecord,state" error in the server log when I click
on the "List of Rooms" link in web admin. That error log is detailed
at http://www.ejabberd.im/mod_muc_admin#comment-59203

I tried going through and destroying every room. Once I was down to
zero, the "List of Rooms" link worked without an error, correctly
showing zero rooms. As soon as I re-added my first room, the errors
returned.

I also tried wiping out ejabberd (with `apt-get remove --purge
ejabberd`) and bringing it back up from scratch, restoring just
mod_muc_admin, our ejabberd.cfg, and our SSL certs, and saw identical
behavior — as soon as we created a first room, we started getting
"badrecord,state" errors when running mod_muc_admin commands.

I can't tell if there's a legitimate problem with our database, or if
I'm seeing bugs in mod_muc_admin. Suggestions appreciated.

Thanks,

  -nat


More information about the ejabberd mailing list