[ejabberd] ejabberd_xmlrpc installation

Alexander Zhebrak fata2ex at gmail.com
Thu Sep 6 19:47:44 MSK 2012


Hello again!

I'm trying to install ejabberd_xmlrpc on my Ubuntu Server by this
manual<http://svn.process-one.net/ejabberd-modules/ejabberd_xmlrpc/trunk/README.txt>
but
every time I start my ejabberd server with new listen option I got:

(<0.37.0>:gen_mod:75) : Problem starting the module mod_adhoc for host
> "myhostname"

 options: []

 exit: {noproc,

           {gen_server,call,

               [ejabberd_iq_sup,

                {start_child,

                    ["myhostname",mod_adhoc,process_local_iq]},

                infinity]}}


in ejabberd.log. (It's running well without '{4560, ejabberd_xmlrpc, []}')

I've recompiled ejabberd and ejabberd_xmlrpc with the same version of
Erlang, but there is no difference.

Erlang R15B02 (erts-5.9.2)
> Ejabberd 2.1.11
> ejabberd_xmlrpc 1.13-ipr2


*New *.beam files in ejabberd/ebin/ are:*

tcp_serv.beam xmlrpc.beam xmlrpc_decode.beam xmlrpc_encode.beam
> xmlrpc_http.beam xmlrpc_util.beam


*ejabberd.cfg changes:*


>  {4650, xmlrpc, []},

or

>  {4560, ejabberd_xmlrpc, []}


(I've tried other ports)

When I had changed name xmlrpc to a random text it has returned me the same
error, so I think ejabberd just can't find new module.

I've tried to add

-pa $EJABBERD_EBIN_PATH /lib/ejabberd/xmlrpc-1.13/ebin\


to /sbin/ejabberdctl, no changes.


Any ideas?

Thanks for your help, I really appreciate it.


-- 
Alexander Zhebrak
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20120906/87f9cb1a/attachment.html>


More information about the ejabberd mailing list