[ejabberd] XEP-0280

Abhinav Singh abhinavsingh at ymail.com
Tue Apr 2 11:56:29 MSK 2013


For others who will be following this thread, mod_message_carbon is tested and developed against ejdv2. I haven't tried it with ejdv3.
From the errors it looks like mod_message_carbon build.sh isn't able to find ejd headers where it expects them to be.
Kindly update Emakefile and build.sh with appropriate include and ebin directory paths for successful compilation.

--
Abhinav Singh
http://abhinavsingh.com/

On 26-Mar-2013, at 2:39 AM, Jorge Guntanis <jorge.guntanis at telcentris.com> wrote:

> Hi,
> 
> I've been trying to get Message Carbons working without luck.
> I tried installing ejabberd 3 beta 3 alpha 3, which according to the commercial ejabberd website has support for it, but when I try to discover the service, it doesn't appear like it's supported, is there anything that I need to add to the config to enable this? I couldn't find much information online.
> 
> Additionally I tried to compile Abhinav Singh contribution module (https://github.com/abhinavsingh/mod_message_carbon) but when I try to build the .beam I get these errors and compilation fails.
> 
> ./mod_message_carbon.erl:61: record iq undefined
> ./mod_message_carbon.erl:62: record jid undefined
> ./mod_message_carbon.erl:62: record jid undefined
> ./mod_message_carbon.erl:62: record jid undefined
> ...
> ...
> 
> Any ideas on how can I achieve XEP-0280 using eJabberd?
> 
> Thanks much,
>  - Jorge
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20130402/80f6543f/attachment.html>


More information about the ejabberd mailing list