[ejabberd] Can't start ejabberd-2.1.11 Windows service and failed to register admin user

Joshua Lim joshualimming at gmail.com
Mon Jul 1 18:57:46 MSK 2013


Hi,

I'm a Windows guy, trying out ejabberd for the first time on my 64 bit
Windows 7 but faced issues that I'm not able to find the solution from the
web, hope you guys can help.

I installed ejabberd-2.1.11 using the Windows installer which I downloaded
from: http://www.process-one.net/en/ejabberd/archive/ I installed "as
administrator" as I saw some posts indicating that this maybe required.

1). The installation was fine, except for one error:

*C:\Program Files (x86)\ejabberd-2.1.11\bin>bash ./ejabberdctl register
"admin" "localhost" "xxxxxxxx" *
*Can't register user admin at localhost at node ejabberd at localhost: not_allowed
*

ps: I've uploaded the whole install.log here -
http://www.2shared.com/file/Ma41Qo8P/ejabberd_logs.html

Next, I set upon to try to register the user manually.  I was able to run
"ejabberdctl live" from bash and "ejabberdctl status" returned:

*bash$ ejabberdctl status*
*The node ejabberd at localhost is started with status: started*
*ejabberd 2.1.11 is running in that node*

However, I'm still not able to register my user.  I've also tried changing
host to my computer name and also a fake domain, but none of them worked.

bash$ bash ./ejabberdctl register "admin" "localhost" *"xxxxxxxx"*
Can't register user admin at localhost at node ejabberd at localhost: not_allowed

btw, I also tried ejabberdctl debug but it returned an error:

*Erlang R14B04 (erts-5.8.5) [smp:4:4] [rq:4] [async-threads:0]*
**** ERROR: Shell process terminated! (^G to start new job) ****


2). The other thing is even though the ejabberd service was created, I
couldn't get it to start.  I also tried setting the service to logon as
administrator, didn't help.

*C:\Users\Fujitsu>net start ejabberd01ce7620f96c04c0*
*The ejabberd service is starting.*
*The ejabberd service could not be started.*
*A system error has occurred.
*
*System error 1067 has occurred.
*
*The process terminated unexpectedly.*

A crash dump is generated, I tried to search keywords related to this dump
but found no conclusive solution.

*=erl_crash_dump:0.1
*
*Mon Jul 01 22:19:50 2013*
*Slogan: init terminating in do_boot ()*
*System version: Erlang R14B04 (erts-5.8.5) [smp:4:4] [rq:4]
[async-threads:0]*
*Compiled: Mon Oct  3 19:19:39 2011*

I've included the full dump file along with the install.log uploaded to
2shared.com.

BTW, one last thing which I didn't mention was that after the first time I
installed, even "ejabberdctl start" didn't work.  It returned some "ps:
command not found"... I didn't note down the exact error.  I managed to fix
that by downloading and placing cgywin\bin into the PATH system variable.


Rgds,
Joshua
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20130701/9750242a/attachment.html>


More information about the ejabberd mailing list