[ejabberd] Ejabberd messages delayed delivery

Saurabh Kumar saurabh.catch at gmail.com
Thu Nov 14 23:05:44 MSK 2013


Although 'ejabberd.cfg' file was alright,  'ejabberdctl reopen-log' worked
for me. Thanks. I will post the logs, whenever I see a glitch.

Saurabh


On Fri, Nov 15, 2013 at 12:27 AM, Mansab Uppal <mansab.uppal at gmail.com>wrote:

> Well, I am not sure about the run time logging. However, you may check
> your 'ejabberd.cfg' file and check if the loglevel is properly defined.
>
> You can also try to reopen the log files after they were renamed by using
> 'ejabberdctl reopen-log'.
>
> Hope that helps.
>
>
> On Fri, Nov 15, 2013 at 12:05 AM, Saurabh Kumar <saurabh.catch at gmail.com>wrote:
>
>> Is there a way to switching ON the logs runtime (without restart)? Logs
>> were ON but somehow the logs file got deleted and the server has stopped
>> logging now.
>>
>> I tried this but does not seem to work.
>>
>>  % erl -sname node1 -remsh ejabberd at localhost
>>   Erlang (BEAM) emulator version 5.6.5 [source] [smp:2] [async-threads:0] [hipe] [kernel-poll:false]
>>
>>   Eshell V5.6.4  (abort with ^G)
>>   (ejabberd at localhost)1> ejabberd_loglevel:set(3).
>>   {module,ejabberd_logger}
>>   (ejabberd at localhost)2>
>>   BREAK: (a)bort (c)ontinue (p)roc info (i)nfo (l)oaded
>>          (v)ersion (k)ill (D)b-tables (d)istribution
>>   %
>>
>> (hitting ^c^c to end the session)
>>
>>
>> On Thu, Nov 14, 2013 at 11:54 PM, Saurabh Kumar <saurabh.catch at gmail.com>wrote:
>>
>>> Thanks for the reply. Will share shortly.
>>>
>>> Saurabh
>>>
>>>
>>> On Thu, Nov 14, 2013 at 11:46 PM, Mansab Uppal <mansab.uppal at gmail.com>wrote:
>>>
>>>> You might need to check the 'ejabberd.logs' for the specific jabber IDs
>>>> and around with which you face the delay.
>>>>
>>>> P.S If possible share the logs here.
>>>>
>>>>
>>>>
>>>>
>>>> On Thu, Nov 14, 2013 at 8:36 PM, Saurabh Kumar <saurabh.catch at gmail.com
>>>> > wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> I am using Ejabberd 2.1.13 with around 500 concurrent connections.
>>>>> Sometimes, chat messages start delivering late (~30s delay)  suddenly and
>>>>> this gets fixed on its own. Any clue on what could cause this? During the
>>>>> faulty behaviour, CPU and Memory consumption stays normal.
>>>>>
>>>>> Saurabh
>>>>>
>>>>> _______________________________________________
>>>>> ejabberd mailing list
>>>>> ejabberd at jabber.ru
>>>>> http://lists.jabber.ru/mailman/listinfo/ejabberd
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Regards,
>>>> Mansab Uppal - mansab.upp.al
>>>> Director, GetTechGo - gettechgo.com <http://www.gettechgo.com/>
>>>> Manager, TeamJabber - teamjabber.com <http://www.teamjabber.com>
>>>>
>>>> _______________________________________________
>>>> ejabberd mailing list
>>>> ejabberd at jabber.ru
>>>> http://lists.jabber.ru/mailman/listinfo/ejabberd
>>>>
>>>>
>>>
>>
>> _______________________________________________
>> ejabberd mailing list
>> ejabberd at jabber.ru
>> http://lists.jabber.ru/mailman/listinfo/ejabberd
>>
>>
>
>
> --
> Regards,
> Mansab Uppal - mansab.upp.al
> Director, GetTechGo - gettechgo.com <http://www.gettechgo.com/>
> Manager, TeamJabber - teamjabber.com <http://www.teamjabber.com>
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20131115/70f05cc6/attachment.html>


More information about the ejabberd mailing list