[ejabberd] Request for help: Changes to max_user_sessions having no effect

David Partain david.partain at ericsson.com
Wed Jul 30 13:56:21 MSK 2014


Hi,

Thanks for the swift response!

I don't know how the clients behave, to be honest.  Whatever's 
happening, it appears to be client-independent, since I've received user 
feedback from people using a number of different clients.

It appears, though, that there's only one XMPP connection per client, 
and I know that I'm multiple muc chatrooms, so we should be ok there.

I'll dig around more in the muc configuration, then.  I know I have 
access and that they're there, since I can join a room as #9, but if I 
then try to log in as room #11, I'll get the 503: Service Unavailable error.

Any suggestions of what I might look for are most welcome.

Cheers,

David

On 07/30/2014 11:40 AM, Kirk Bateman wrote:
> max_user_sessions has nothing to do with muc chatrooms unless your
> client is creating a new XMPP connection per room (not good idea).
>
> Check the muc config is OK, do the rooms exist and do the users have
> access to them, check muc_admin etc..
>
> Hope that helps
>
> Kirk Bateman
>
> On 30 Jul 2014 10:32, "David Partain" <david.partain at ericsson.com
> <mailto:david.partain at ericsson.com>> wrote:
>
>     Greetings,
>
>     I apologize in advance if this is a FAQ.  I've tried to find the
>     answer, but rather than go completely bald pulling out the rest of
>     my hair, I'm hoping someone here can help.
>
>     I'm running ejabberd 2.1.10 on an Ubuntu 12.04 server.
>
>     The initial config had
>
>     {access, max_user_sessions, [{10, all}]}.
>
>     and users were (not surprisingly) only able to connect to 10 chat
>     rooms.  When they connected to the 11th, they got a 503 go-away error.
>
>     I thought that it would be a simple matter of changing that to
>     something else like:
>
>     {access, max_user_sessions, [{100, all}]}.
>
>     and restarting the server.  No luck.  11th chat room results in the
>     same error.
>
>     Then I thought I had found something with the override_* options.  I
>     commented those out, so I have:
>
>     override_global.
>     override_local.
>     override_acls.
>
>     Unfortunately, this changes nothing, either.
>
>     I realize this looks like I'm fumbling in the dark, 'cause I am.
>       I'm relatively new to the ejabberd game.
>
>     Can anyone suggest what I might be overlooking?
>
>     Thanks.
>
>     David



More information about the ejabberd mailing list