[ejabberd] S2S and starttls not working

Sven-Haegar Koch haegar at sdinet.de
Tue Nov 25 23:42:22 MSK 2014


On Tue, 25 Nov 2014, Thomas Martin wrote:

> 2014-11-25 15:09 GMT+01:00 Holger Weiß <holger at zedat.fu-berlin.de>:
> > * Thomas Martin <tmartincpp at gmail.com> [2014-11-25 12:18]:
> >> If I set "s2s_use_starttls" to "true" the s2s connection don't work
> >> (no connection established).
> >
> > Can you talk to other remote servers, or have you just tried this one?
> > Older ejabberd versions can stumble over certificates with incorrect
> > host names, for example.
> >
> I never tried others servers (and my servers don't have access to internet).
> I will double-check certificates but users are able to connect without
> issues with sames certificates and domains.

What key sizes are you using in your certificates?

With old ejabberd versions we had problems with RSA keys longer than 
2048 bit, and they manifested exactly as disconnects without any 
helpfull log entries.

c'ya
sven-haegar

-- 
Three may keep a secret, if two of them are dead.
- Ben F.


More information about the ejabberd mailing list