[ejabberd] XmlRpc failed on some commands, seems require auth, but how?

Jiejing.Zhang kzjeef at gmail.com
Wed Sep 3 07:01:16 MSK 2014


Thanks Vladimir, After delete those two lines, I can manage pass my test.

I copy this config from some project when setup my ubuntu server.

Thanks again.

Jiejing


Best regards,
Zhang Jiejing


On Tue, Sep 2, 2014 at 1:37 PM, Vladimir Stafievsky <
vladimir.stafievsky at syncopate.ru> wrote:

>  http://www.ejabberd.im/ejabberd_xmlrpc There are some php-examples how
> to provide auth information, may be it help.
>
> Another way:
> Delete
>     access_commands:
>           configure:
>             all: []
> these derectives from your config file and add ip: "127.0.0.1" or disable
> access to xmlrpc port via firewall.
>
> In our installation we don't use authorization for xmlrpc module, just
> firewalled it.
>
> 01.09.2014 20:37, Jiejing.Zhang пишет:
>
> Hi,
>
>  I have an issue when using ejabberd 14.07 (latest, also 13.02) do some
> ejabberd and xml_rpc to build my application.
>
>  I can use xmlrpc to list user's roster when I development on Mac(14.07),
> but when I deployment it to Ubuntu server, I cannot get the correct result
> back from xmlrpc.
>
>  The error message is like:
>
>  `2014-08-19 05:15:47.159 [error] <0.545.0>
> {xmlrpc_http,171,{ejabberd_xmlrpc,handler,{'EXIT',{{badmatch,no_auth_provided},[{ejabberd_commands,check_access,2,[{file,"src/ejabberd_commands.erl"},{line,402}]},{ejabberd_commands,'-check_access_commands/5-fun-0-',5,[{file,"src/ejabberd_commands.erl"},{line,373}]},{lists,'-filter/2-lc$^0/1-0-',2,[{file,"lists.erl"},{line,1271}]},{ejabberd_commands,check_access_commands,5,[{file,"src/ejabberd_commands.erl"},{line,371}]},{ejabberd_commands,execute_command,4,[{file,"src/ejabberd_commands.erl"},{line,308}]},{ejabberd_xmlrpc,do_command,6,[{file,"src/ejabberd_xmlrpc.erl"},{line,350}]},{ejabberd_xmlrpc,try_do_command,6,[{file,"src/ejabberd_xmlrpc.erl"},{line,313}]},{xmlrpc_http,eval_payload,7,[{file,"src/xmlrpc_http.erl"},{line,166}]}]}}}}
> `
>
>  And I have checked the source code, and I found it seems caused by the
> execute_command require an auth information.
>
>  But I don't know how to pass auth information in xml_rpc, also I don't
> find any example by google.
>
>  I have posted my entire config & error log  & test script in
> https://github.com/processone/ejabberd/issues/279
>
>  But I don't get response for about 2 weeks.
>
>  Could some one give some tip on this issue.
>
>  Thanks,
> Jiejing
>
> Best regards,
> Zhang Jiejing
>
>
> _______________________________________________
> ejabberd mailing listejabberd at jabber.ruhttp://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
>
> --
> Wbr,
>
> Vladimir Stafievsky
>
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20140903/d24c4de9/attachment.html>


More information about the ejabberd mailing list