[ejabberd] Error when starting ejabberd Community 15.03

Peter Viskup skupko.sk at gmail.com
Mon Mar 30 16:04:47 MSK 2015


On Mon, Mar 30, 2015 at 3:01 PM, Peter Viskup <skupko.sk at gmail.com> wrote:

> Had same issue during last upgrade two weeks before.
> I upgraded from packages available on jabber.at Debian repo. First I did
> backups of the Mnesia data files (do ODBC dump once some RDBMS used), then
> upgrade ejabberd and start the new version and run the command from the
> how-to [1], then stop ejabberd, save the newly generated config in the
> expected location, restore the data backups and start the ejabberd server.
>
> It will automagically convert the data structures to new format. That
> could take a while (in our case - jabber.sk it took approx. 4-6 hours,
> the roster DB was recreated during startup). Then you can expect some
> client connection issues caused by PubSub. The simplest solution was to
> remove "pubsub_node" data file and start the ejabberd (of course PubSub
> info were lost).
>
> Hope it helped a little.
>
> [1] https://blog.process-one.net/switch-ejabberd-configuration-to-yaml/
>

Forget to mention you should have enough free space for data files in
filesystem as those will be migrated to new format and it is done by
creating some temporary tables in Mnesia - not sure about RDBMS.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20150330/45f5a086/attachment.html>


More information about the ejabberd mailing list