[ejabberd] Problem using a custom authentication

Steven Livingstone steven at livz.org
Sun Sep 18 22:57:23 MSK 2016


Hmmm, there is not one but rather a fairly chunky set of updates by
@mremond as shown here:

https://github.com/processone/ejabberd/compare/16.03...16.04

Looking into what could be the issue but no joy after a day of
debugging so any help much appreciated.

steven

On Sat, Sep 17, 2016 at 6:09 PM, Steven Livingstone <steven at livz.org> wrote:
> Hi, I have created an authentication module which was build against
> 16.02 and runs fine when auth_method is set. It also works against
> 16.03.
>
> However, from 16.04 onwards it gives me the error "[error] ignoring
> option 'auth_method' with invalid value: [jwt]"
>
> I checked the code diff between those releases and the only change
> seems to be to the mod_pubsub.erl file, specifically adding the
> following:
>
> ServerHost = serverhost(Host),
> + ejabberd_hooks:run(pubsub_subscribe_node, ServerHost,
> + [ServerHost, Host, Node, Subscriber, SubId]),
>
>
> https://github.com/processone/ejabberd/commit/639c2fb6401391663206c0e4c946d1a699689ac7
>
> I have tried disabling this module and even deleting the beam file as
> i don't use it, but i can't seem ti get round it.
>
> Does anyone have any insight as to why these changes will have broken
> my authentication module?
>
> My source is at the link below, but as i say has worked fine for a year:
> https://github.com/ParamountVentures/ejabberd-auth-jwt
>
> many thanks,
> steven


More information about the ejabberd mailing list