[ejabberd] Problem using a custom authentication

Steven Livingstone steven at livz.org
Mon Sep 19 09:58:31 MSK 2016


Oh, I can't see that error. Is this in the ejabberd log file or are you
using some other way debug? I'm fairly new to debugging Erlang so learning
as I go!

Thanks
Steven

On 19 Sep 2016 7:31 a.m., "Evgeny Khramtsov" <xramtsov at gmail.com> wrote:

Sat, 17 Sep 2016 18:09:06 +0100
Steven Livingstone <steven at livz.org> wrote:

> However, from 16.04 onwards it gives me the error "[error] ignoring
> option 'auth_method' with invalid value: [jwt]"
> ...
> My source is at the link below, but as i say has worked fine for a
> year: https://github.com/ParamountVentures/ejabberd-auth-jwt

I put ejabberd_auth_jwt.erl in src directory of the latest ejabberd
(master branch), and set auth_method: jwt
I got ejabberd running without configuration error and it saw the
method:
(ejabberd1 at zinid.ru)1> ejabberd_auth:auth_modules(<<"localhost">>).
[ejabberd_auth_jwt]
It doesn't have however, because of auth API change in the latest
ejabberd:
09:21:23.695 [error] gen_fsm <0.649.0> in state
wait_for_feature_request terminated with reason: call to undefined
function ejabberd_auth_jwt:check_password(<<"user1">>, <<"user1">>,
<<"localhost">>, <<"pass1">>) 09:21:23.695 [error] CRASH REPORT Process
<0.649.0> with 0 neighbours exited with reason: call to undefined
function ejabberd_auth_jwt:check_password(<<"user1">>, <<"user1">>,
<<"localhost">>, <<"pass1">>) in p1_fsm:terminate/8 line 760
_______________________________________________
ejabberd mailing list
ejabberd at jabber.ru
http://lists.jabber.ru/mailman/listinfo/ejabberd
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20160919/183d0c87/attachment.html>


More information about the ejabberd mailing list