[ejabberd] Problem using a custom authentication

Steven Livingstone steven at livz.org
Mon Sep 19 11:19:28 MSK 2016


Wonderful Evgeny - that works perfectly now after a small code update.
So it seems you can no longer have the auth beam file external and
rather need to compile with the source. Doesn't seem to be the case
for mod_* i have, just auth modules.

I will see if i can suggest it be added to the main repo as an
additional auth method as a few people have asked how to get it
working again but given i'm certainly no Erlang expert this may not
happen quickly, or at all :-)

Thank you for somewhat saving my sanity !

cheers,
steven

On Mon, Sep 19, 2016 at 8:26 AM, Steven Livingstone <steven at livz.org> wrote:
> Interesting - ok i will try that and see how i get on. I was compiling
> the beam and dropping it into the ebin folder for 16.02/16.03 but i
> will try this out just now.
>
> Appreciate your help.
>
>
> On Mon, Sep 19, 2016 at 8:20 AM, Evgeny Khramtsov <xramtsov at gmail.com> wrote:
>> Mon, 19 Sep 2016 08:12:49 +0100
>> Steven Livingstone <steven at livz.org> wrote:
>>
>>> How did you compile the source ejabberd_auth_jwt?
>>
>> Nothing special. I just copied your ejabberd_auth_jwt.erl into
>> ejabberd's `src` directory, typed `make` and then started ejabberd,
>> e.g.:
>>
>> $ cp ejabberd_auth_jwt.erl blah/src/ejabberd_auth_jwt.erl
>> $ cd blah/blah/blah
>> $ make
>> $ ./some-ejabberd-start-script.sh
>> _______________________________________________
>> ejabberd mailing list
>> ejabberd at jabber.ru
>> http://lists.jabber.ru/mailman/listinfo/ejabberd


More information about the ejabberd mailing list