[ejabberd] bad_type,ejabberd_commands,gen_html_doc_for_commands

jacob jabber ejabberd.jacob at gmail.com
Mon Feb 6 16:24:52 MSK 2017


*Hi I using ejabberd 16.09 after cluserting, *

Nodes is running and operational, even being listed as part of the cluster
and routing messages. But extra commands are broken. In summary ejabberdctl
is not usable at this state.
Except ejabberdctl status is working and another command return this error:

ejabberdctl list_cluster command:
Problem 'exit {aborted,
                  {no_exists,
                      [ejabberd_commands,
                       [{{ejabberd_commands,'$1','_','_','_','$2','_','_',
                             '_','_','_','_','_','_','_','_'},
                         [{'==','$1',{const,list_cluster}},
                          {'=<','$2',{const,1000000}}],
                         [{{'$2','$_'}}]}]]}}' occurred executing the
command.
Stacktrace: [{mnesia,abort,1,[{file,"mnesia.erl"},{line,313}]},
             {ejabberd_commands,get_command_definition,2,
                                [{file,"src/ejabberd_commands.erl"},
                                 {line,419}]},
             {ejabberd_commands,get_command_format,3,
                                [{file,"src/ejabberd_commands.erl"},
                                 {line,381}]},
             {ejabberd_ctl,call_command,4,
                           [{file,"src/ejabberd_ctl.erl"},{line,318}]},
             {ejabberd_ctl,try_call_command,4,
                           [{file,"src/ejabberd_ctl.erl"},{line,298}]},
             {ejabberd_ctl,process2,4,
                           [{file,"src/ejabberd_ctl.erl"},{line,247}]},
             {ejabberd_ctl,process,2,
                           [{file,"src/ejabberd_ctl.erl"},{line,225}]},
             {rpc,'-handle_call_call/6-fun-0-',5,
                  [{file,"rpc.erl"},{line,206}]}]

I joind one of nodes with ejabberd 16.04 and that working fine.

when restart ejabberd 16.09 in cluster, it return this error and is not
started:

0.20064.1> CRASH REPORT Process <0.20064.1> with 0 neighbours exited
with reason:
{aborted,{bad_type,{ejabberd_commands,gen_html_doc_for_commands,[documentation],"Generates
html documentation for
ejabberd_commands",[],0,ejabberd_commands_doc,generate_html_output,[{file,binary},{regexp,binary},{examples,binary}],restricted,[],{res,rescode},["Path
to file where generated documentation should be stored","Regexp matching
names of commands or modules that will be included inside generated
document","Comma separated list of languages (choosen from java, perl,
xmlrpc, json)that ..."],...}}} in application_master:init/4 line 134
2017-02-06 15:58:36.195 [info] <0.20033.1> Application ejabberd exited with
reason:
{aborted,{bad_type,{ejabberd_commands,gen_html_doc_for_commands,[documentation],"Generates
html documentation for
ejabberd_commands",[],0,ejabberd_commands_doc,generate_html_output,[{file,binary},{regexp,binary},{examples,binary}],restricted,[],{res,rescode},["Path
to file where generated documentation should be stored","Regexp matching
names of commands or modules that will be included inside generated
document","Comma separated list of languages (choosen from java, perl,
xmlrpc, json)that ..."],...}}}

I change src/ejabberd_cluster.erl from this link(
https://github.com/processone/ejabberd/issues/1210) but not working.
how fix that,
thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20170206/d5cb74e6/attachment.html>


More information about the ejabberd mailing list