[ejabberd] lost messages

jacob jabber ejabberd.jacob at gmail.com
Wed Jan 18 09:46:45 MSK 2017


thanks for kind response.
I want to sure my stream management work fine, for that I do this
scenario(disconnect internet connection and connect to internet before chat
server know this disconnection), but I lose 1 message that chat server
receive that but my second client did'nt receive that message. when client
connect to internet  then chat server, client back this error(stream error)

<stream:error><conflict
xmlns='urn:ietf:params:xml:ns:xmpp-streams'></conflict><text xml:lang='en'
xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Replaced by new
connection</text></stream:error>">>

ejabberd config:
    stream_management: true
    resend_on_timeout: if_offline
    resume_timeout: 10
    zlib: true
    max_ack_queue: 10000

My client use smack 4.1.9

thanks alot holger.



On Tue, Jan 17, 2017 at 12:30 PM, <ejabberd-request at jabber.ru> wrote:

> Send ejabberd mailing list submissions to
>         ejabberd at jabber.ru
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         http://lists.jabber.ru/mailman/listinfo/ejabberd
> or, via email, send a message with subject or body 'help' to
>         ejabberd-request at jabber.ru
>
> You can reach the person managing the list at
>         ejabberd-owner at jabber.ru
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of ejabberd digest..."
>
>
> Today's Topics:
>
>    1. lost messages (jacob jabber)
>    2. Re: lost messages (Holger Wei?)
>    3. mod_shared_roster_ldap on Active Directory (Anthony BERGER)
>    4. message loss (jacob jabber)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 16 Jan 2017 13:24:48 +0330
> From: jacob jabber <ejabberd.jacob at gmail.com>
> To: ejabberd at jabber.ru
> Subject: [ejabberd] lost messages
> Message-ID:
>         <CAOY1yjCK3_Ybg8wU8yA8+ibzcAcHBnVvkK4jEPWTxiFVTEYuvg@
> mail.gmail.com>
> Content-Type: text/plain; charset="utf-8"
>
> Hi. I get this error for stream management using smack and ejabberd 16.02
> and ejabberd 16.04:
>
> <stream:error><conflict
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'></conflict><text xml:lang='en'
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Replaced by new
> connection</text></stream:error>"
>
> I lost(disconnect) client1 internet connection for 60 second and client 2
> sends messages in this interval(60 messages) to clinet 1. when client 1
> connects to internet, this error happens and is lost 1 message(first
> message) and this error happens.
> ejabberd server received lost message and but client 1 no received that
> message.
>  what's wrong, Is this error ok or bug?
>
> thanks alot in advance.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.jabber.ru/pipermail/ejabberd/
> attachments/20170116/2f7d224f/attachment-0001.html>
>
> ------------------------------
>
> Message: 2
> Date: Mon, 16 Jan 2017 11:08:24 +0100
> From: Holger Wei? <holger at zedat.fu-berlin.de>
> To: ejabberd List <ejabberd at jabber.ru>
> Subject: Re: [ejabberd] lost messages
> Message-ID: <20170116100824.GO108209 at zedat.fu-berlin.de>
> Content-Type: text/plain; charset=iso-8859-1
>
> * jacob jabber <ejabberd.jacob at gmail.com> [2017-01-16 13:24]:
> > <stream:error><conflict
> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'></conflict><text
> xml:lang='en'
> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Replaced by new
> > connection</text></stream:error>"
>
> If you got this error, the client didn't resume? the old session but
> created a new one instead.  This error is then sent over the *old*
> connection, so it seems you didn't actually loose it.
>
> > I lost(disconnect) client1 internet connection for 60 second and client 2
> > sends messages in this interval(60 messages) to clinet 1. when client 1
> > connects to internet, this error happens and is lost 1 message(first
> > message) and this error happens.
> > ejabberd server received lost message and but client 1 no received that
> > message.
> >  what's wrong, Is this error ok or bug?
>
> This FAQ entry might clarify some details around stream management:
>
>         https://www.ejabberd.im/faq/tcp
>
> But my first question would be why you thought you lost the connection
> while it looks like you didn't.
>
> Holger
>
> ? https://xmpp.org/extensions/xep-0198.html#resumption
>
>
> ------------------------------
>
> Message: 3
> Date: Mon, 16 Jan 2017 15:02:08 +0100
> From: Anthony BERGER <anthony.berger at bioaster.org>
> To: ejabberd at jabber.ru
> Subject: [ejabberd] mod_shared_roster_ldap on Active Directory
> Message-ID: <d080aa6c-7d3f-4fd7-1ca2-fd02fad741b7 at bioaster.org>
> Content-Type: text/plain; charset=utf-8; format=flowed
>
> i try to configure msrl but no luck !
>
> maybe somebody can help me
>
> i have a ejabber group which contains 2 groups : GroupA and GroupB (i
> try to use this to build rfilter)
> my user are in service groupA or group B .
> i try to build 2 roster group : A and B containing users from groups
>
> this is my users :
> dn:cn=toto tata,ou=S1,dc=domain,dc=fr
> sAMAccountName:ttata
> ...
>
> my jabber group:
> dn:cn=ejabgroup,ou=grp,dc=domain,dc=fr
> member:cn=serviceA,ou=grp,dc=domain,dc=fr
> member:cn=serviceB,ou=grp,dc=domain,dc=fr
>
>
> my services groups:
> dn:cn=serviceA,ou=grp,dc=domain,dc=fr
> member: cn=toto tata,ou=S1,dc=domain,dc=fr
>
>
>
> -------------------------------------------------
>
> WHAT 's wrong
>
>
> this is my conf for msrl :
>     mod_shared_roster_ldap:
>      ldap_base: "dc=bioaster,dc=local"
> ##    ldap_rfilter:
> "(memberof=cn=ejabberd_groups,OU=ejabberd,OU=Application,OU=
> GroupeSecu,DC=Bioaster,DC=local)"
> ##
>      ldap_groupattr: "distinguishedName"
> ##
>      ldap_gfilter: "(&(objectClass=group)(distinguishedName=%g))"
>      ldap_groupdesc: "cn"
>      ldap_memberattr: "member"
> ##
>      ldap_ufilter: "distinguishedName=%u"
>      ldap_useruid: "sAMAccountName"
>      ldap_userdesc: "displayName"
>      ldap_group_cache_validity: 1
>      ldap_user_cache_validity: 1
>      ldap_auth_check: off
>
>
>
> ------------------------------
>
> Message: 4
> Date: Tue, 17 Jan 2017 09:59:41 +0330
> From: jacob jabber <ejabberd.jacob at gmail.com>
> To: ejabberd at jabber.ru
> Subject: [ejabberd] message loss
> Message-ID:
>         <CAOY1yjB1Ps-xcOukkawDG5Pbz101=LucppxG02K1FX=PfZ8_Cg at mail.
> gmail.com>
> Content-Type: text/plain; charset="utf-8"
>
> Hi. I get this error for stream management using smack and ejabberd 16.02
> and ejabberd 16.04:
>
> <stream:error><conflict
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'></conflict><text
> xml:lang='en' xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Replaced by new
> connection</text></stream:error>"
>
> I lost(disconnect) client1 internet connection for 60 second and client 2
> sends messages in this interval(60 messages) to clinet 1. when client 1
> connects to internet, this error happens and is lost 1 message(first
> message) and this error happens.
> ejabberd server received lost message and but client 1 no received that
> message.
>  what's wrong, Is this error ok or bug?
>
> thanks alot in advance.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.jabber.ru/pipermail/ejabberd/
> attachments/20170117/635d5014/attachment-0001.html>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
> ------------------------------
>
> End of ejabberd Digest, Vol 162, Issue 7
> ****************************************
>



-- 

*Best Regards*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20170118/a3f7b6e2/attachment.html>


More information about the ejabberd mailing list