[ejabberd] Problem starting ejabberd

Abhishek Ranjan abhishek at blacklightsw.com
Mon May 8 11:36:45 MSK 2017


I have gone through the installations steps again and the ejabberdctl live this time works but with few errors as given below

[error] unknown option 'mod_register' for module 'mod_pubsub' will be likely ignored, available options are: 'access_createnode', 'db_type', 'host', 'ignore_pep_from_offline', 'iqdisc', 'last_item_cache', 'max_items_node', 'nodetree', 'pep_mapping', 'plugins', 'max_subscriptions_node', 'default_node_config'


08:23:18.479 [error] unknown option 'welcome_message' for module 'mod_pubsub' will be likely ignored, available options are: 'access_createnode', 'db_type', 'host', 'ignore_pep_from_offline', 'iqdisc', 'last_item_cache', 'max_items_node', 'nodetree', 'pep_mapping', 'plugins', 'max_subscriptions_node', 'default_node_config'


08:23:18.498 [error] unknown option 'ip_access' for module 'mod_pubsub' will be likely ignored, available options are: 'access_createnode', 'db_type', 'host', 'ignore_pep_from_offline', 'iqdisc', 'last_item_cache', 'max_items_node', 'nodetree', 'pep_mapping', 'plugins', 'max_subscriptions_node', 'default_node_config'


08:23:18.506 [error] unknown option 'access_from' for module 'mod_pubsub' will be likely ignored, available options are: 'access_createnode', 'db_type', 'host', 'ignore_pep_from_offline', 'iqdisc', 'last_item_cache', 'max_items_node', 'nodetree', 'pep_mapping', 'plugins', 'max_subscriptions_node', 'default_node_config'


08:23:18.512 [error] unknown option 'access' for module 'mod_pubsub' will be likely ignored, available options are: 'access_createnode', 'db_type', 'host', 'ignore_pep_from_offline', 'iqdisc', 'last_item_cache', 'max_items_node', 'nodetree', 'pep_mapping', 'plugins', 'max_subscriptions_node', 'default_node_config'


As I can see it is pointing out errors at mod_register,welcome message,ip-access,access and these the are the places in the ejaabberd.yml I have either un-commented something (mod_register and welcome message and all)

or either changed the entries like  access :deny  to  access: register.

But I run ejabberd with these edited confugurations on some other pc also(and it runs fine there) then why is it giving error now?

Any suggetions please?

Checkout my awesome apps on Google Play Store https://play.google.com/store/apps/dev?id=7448460448507458941  and iOS http://bit.ly/bsw_iOS

> On May 8, 2017 at 1:10 PM Abhishek Ranjan <abhishek at blacklightsw.com> wrote:
> 
>     Yes I it is missing from there but what possibly could have gone wrong.I followed the steps
>     below:
> 
>     ./autogen.sh
>     ./rebar get-deps
>     ./configure --enable-mysql
>     ./configure
>     make
>     sudo make install
> 
>     > On May 8, 2017 at 12:54 PM Evgeny Khramtsov <xramtsov at gmail.com> wrote:
>     >
>     >
>     > Mon, 8 May 2017 12:54:31 +0530 (IST)
>     > Abhishek Ranjan <abhishek at blacklightsw.com> wrote:
>     >
>     > > {undef,[{ejabberd_c2s,socket_type,[],[]}
>     >
>     > This means something is wrong with your installation: ejabberd_c2s.beam
>     > file is not found. Check your 'ebin' directory (the directory
>     > containing all "beam" files, i.e. bytecode files).
>     > _______________________________________________
>     > ejabberd mailing list
>     > ejabberd at jabber.ru
>     > http://lists.jabber.ru/mailman/listinfo/ejabberd
> 


 

> _______________________________________________
>     ejabberd mailing list
>     ejabberd at jabber.ru
>     http://lists.jabber.ru/mailman/listinfo/ejabberd
> 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20170508/1a3d1abd/attachment-0001.html>


More information about the ejabberd mailing list