[ejabberd] Ejabberd crashes on as soon as user connects to it

Evgeny Khramtsov xramtsov at gmail.com
Mon May 8 13:32:08 MSK 2017


Mon, 8 May 2017 15:56:10 +0530 (IST)
Abhishek Ranjan <abhishek at blacklightsw.com> wrote:

> I am using pidgin client to make a chat application using ejabberd
> server. Ejabberd server allowed the two users to register . But after
> that when any of the two users try to connect the server crashes with
> the following error :
> 
> [error] gen_server <0.480.0> terminated with reason: no function
> clause matching ejabberd_c2s:bind(<<"-">>, #{auth_module =>
> ejabberd_auth_mnesia,csi_queue => {0,0,#{}},csi_state => active,ip =>
> {{203,92,...},...},...}) line 388
> 
> 
>  [error] CRASH REPORT Process <0.480.0> with 0 neighbours exited with
> reason: no function clause matching ejabberd_c2s:bind(<<"-">>,
> #{auth_module => ejabberd_auth_mnesia,csi_queue =>
> {0,0,#{}},csi_state => active,ip => {{203,92,...},...},...}) line 388
> in p1_server:terminate/7 line 878
> 
> 
>  [error] Supervisor ejabberd_c2s_sup had child undefined started with
> {ejabberd_c2s,start_link,undefined} at <0.480.0> exit with reason no
> function clause matching ejabberd_c2s:bind(<<"-">>, #{auth_module =>
> ejabberd_auth_mnesia,csi_queue => {0,0,#{}},csi_state => active,ip =>
> {{203,92,...},...},...}) line 388 in context child_terminated
> 
> 

We need a full error from crash.log. Also, looks like an installation
mess again (a mix of different versions of beam files).


More information about the ejabberd mailing list