[ejabberd] Ejabberd crashes on as soon as user connects to it

Abhishek Ranjan abhishek at blacklightsw.com
Mon May 8 14:54:30 MSK 2017


I am using erlang 17.1 (erts-6.1).
I should also tell you that I am using Amazon aws linux instance. Both erlang and ejabberd are installed on the linux instance.
I am using a windows system where the clients app (Pidgin) is present.

> On May 8, 2017 at 5:20 PM Evgeny Khramtsov <xramtsov at gmail.com> wrote:
>
>
> Mon, 8 May 2017 16:55:07 +0530 (IST)
> Abhishek Ranjan <abhishek at blacklightsw.com> wrote:
>
> > The full log is attached with this mail
>
> The bug is really odd. I formatted your state a bit and got the
> following:
>
> #{auth_module => ejabberd_auth_mnesia,
> csi_queue => {0,0,#{}},
> csi_state => active,
> ip => {{203,92,39,138},63054},
> lang => <<>>,
> lserver => <<"bsw.com">>,
> mgmt_ack_timeout => 60000,
> mgmt_max_queue => 1000,
> mgmt_max_timeout => 300,
> mgmt_resend => false,
> mgmt_stanzas_in => 0,
> mgmt_stanzas_out => 0,
> mgmt_stanzas_req => 0,
> mgmt_state => inactive,
> mgmt_timeout => 300,
> mod => ejabberd_c2s,
> owner => <0.480.0>,
> pres_a => {0,nil},
> pres_t => {0,nil},
> resource => <<>>,
> server => <<"bsw.com">>,
> socket =>{socket_state,fast_tls,{tlssock,#Port<0.16030>,#Port<0.16088>},<0.479.0>},
> socket_monitor => #Ref<0.0.0.11915>,
> sockmod => ejabberd_socket,
> stream_authenticated => true,
> stream_compressed => false,
> stream_direction => in,
> stream_encrypted => true,
> stream_header_sent => true,
> stream_id => <<"6353065357676519408">>,
> stream_restarted => true,
> stream_state => wait_for_bind,
> stream_timeout => {30000,1494240497693},
> stream_version => {1,0},
> tls_enabled => true,
> tls_required => false,
> lang => <<"en">>,
> access => c2s,
> tls_options => [compression_none,
> {protocol_options,<<"no_sslv3">>},
> {certfile,<<"/etc/ejabberd/server.pem">>}],
> pres_f => {0,nil},
> tls_verify => false,
> shaper => c2s_shaper,
> lserver => <<"bsw.com">>,
> server => <<"bsw.com">>,
> user => <<"raghav">>,
> xmlns => <<"jabber:client">>,
> zlib => false}.
>
> Some fields such as `lang` or `server` are printed twice, and they
> shouldn't (Erlang bug?) Also, all required fields present in the state,
> so there should not be function_clause error. What version of Erlang are
> you using?
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20170508/1129bf30/attachment.html>


More information about the ejabberd mailing list