[ejabberd] Ejabberd crashes on as soon as user connects to it

Evgeny Khramtsov xramtsov at gmail.com
Mon May 8 15:09:31 MSK 2017


Mon, 8 May 2017 17:30:01 +0530 (IST)
Abhishek Ranjan <abhishek at blacklightsw.com> wrote:

> But I read somewhere that to work with ejabberd-17.03 erlang-17.1 or
> higher should be present in the system, and that is why i used
> erlang-17.1.

Indeed, this is written in README, and should be fixed.

> And if this version of erlang is not correct then which erlang
> version should I use?

Anything starting from 17.5 (inclusively). At least we have test suite
successfully passing versions of Erlang starting from 17.5.

However, 17.x and 18.x have been shown to have some severe bugs
(including emulator crashes under heavy load), so I personally prefer
19.x


More information about the ejabberd mailing list