[ejabberd] asn1ct undef error while installing ejabberd

Ashwin Baboji ash.baboji at gmail.com
Sat May 13 08:48:39 MSK 2017


No, it does not. I can not even run "ejabberdctl status" on stopped
ejabberd.

I searched this and erlang mailing list, a 12 year old post (
http://erlang.org/pipermail/erlang-questions/2005-April/015269.html ) has
given some food for thought. The "ejabberdctl" command requires epmd
service running on port 4369, so in order to debug, I ran epmd in debug
mode and did these steps :


1. "erl -sname myname", the node started successfully and I can see log in
epmd terminal for this command.
2. "telnet 127.0.0.1 4369", successfully connects and I can see log in epmd
terminal
3. "telnet localhost 4369", successfully connects and I can see log in epmd
terminal
4. "sudo ejabberdctl status", gives the error AND I see no activity in epmd
terminal.

So ejabberdctl is trying to connect to epmd but on what IP?

Then I did "vim /sbin/ejabberdctl", and found a variable
"ERL_EPMD_ADDRESS", which is definitely the IP that ejabberd is using to
connect to epmd service. But I could not find where it is actually defined.

That's where I am stuck now.

On Sat, May 13, 2017 at 10:10 AM, Evgeny Khramtsov <xramtsov at gmail.com>
wrote:

> Sat, 13 May 2017 00:23:28 +0530
> Ashwin Baboji <ash.baboji at gmail.com> wrote:
>
> > I am using the ejabberd.yml file without any change at all. I opened
> > 5222, 5269 and 5280 on my machine but still same error.
>
> Try to comment all listen sections (i.e. disable all listening
> ip/ports). Does it start in this case?
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20170513/8b9317fd/attachment.html>


More information about the ejabberd mailing list