[ejabberd] Compliance Tester and XEP-0368

Holger Weiß holger at zedat.fu-berlin.de
Mon Nov 6 16:08:39 MSK 2017


* Nk <nk at os.vu> [2017-11-06 12:54]:
> > > I don't understand why 0313 would fail. This is my config:
>
> > Probably because ejabberd doesn't support the latest XEP version?
>
> Ok I see, is this on the development timeline? Do we know what is missing specifically?

I listed things here:

https://github.com/processone/ejabberd/issues/1344#issuecomment-320675112

> I don't think Conversations is sending the ALPN indication

I think it does, at least it there's code to do that:

https://github.com/siacs/Conversations/blob/1.21.0/src/main/java/eu/siacs/conversations/xmpp/XmppConnection.java#L389

But personally I don't let sslh look at ALPN either, just SNI and
unencrypted protocols.

Holger


More information about the ejabberd mailing list