[ejabberd] Recover data from archive_msg.DAT (SOLVED)

pitchum pitchum at gramaton.org
Tue Feb 13 12:10:59 MSK 2018


Le 13/02/2018 à 00:34, Holger Weiß a écrit :
> * pitchum <pitchum at gramaton.org> [2018-02-07 11:26]:
>> Would it be possible to make ejabberdctl commands accept absolute paths?
> 
> They do, so if this didn't work for you (in what way did it fail?)

It did not actually fail. I just couldn't find the generated file at the
location that I specified so I thought it had vanished.


>, I'd
> guess you stumbled over some other issue.  For example, you might've
> started ejabberd via systemd and then tried to specify a path that's
> protected as per your systemd unit configuration.

Indeed, the systemd unit shipped in Debian has this:

    PrivateTmp=true
    ProtectHome=true
    ProtectSystem=full

Because of PrivateTmp=true the generated SQL dump was to be found
somewhere in /tmp/systemd-private-xxxxxxx-ejabberd.service-XADFsf/.
I didn't know about this stuff. Thanks for the tip!


Now I'm a bit confused about the situation.
It is neither a bug in ejabberd nor in Debian nor in systemd.
It's a bug in user's mind who doesn't know enough about systemd.
Where can I report such a bug?

It would be nice if ejabberdctl could print a message at the end
indicating the real pathname of the generated file but I guess it would
go against the purpose of PrivateTmp so it's probably not possible.

-- 
pitchum


More information about the ejabberd mailing list