[ejabberd] ?==?utf-8?q? Beam consumes > 400% CPU - why?

Michael Vogel icarus at dabo.de
Mon Mar 5 17:52:35 MSK 2018


 
Am Montag, 05. März 2018 14:52 CET, Holger Weiß <holger at zedat.fu-berlin.de> schrieb: 
 
> You could post the output of "etop -sort reductions"

It's here:
========================================================================================
 etop at ...                                                               14:50:21
 Load:  cpu         0               Memory:  total       14716    binary        113
        procs      36                        processes    4268    code         4043
        runq        0                        atom          198    ets           241

Pid            Name or Initial Func    Time    Reds  Memory    MsgQ Current Function
----------------------------------------------------------------------------------------
<0.54.0>       user                     '-'    5909   26520       0 group:server_loop/3 
<0.62.0>       etop_txt:init/1          '-'    2078   67856       0 etop:update/1       
<0.53.0>       user_drv                 '-'     559   18616       0 user_drv:server_loop
<0.0.0>        init                     '-'       0   10664       0 init:boot_loop/2    
<0.1.0>        erts_code_purger         '-'       0    2608       0 erts_code_purger:loo
<0.3.0>        etop_server              '-'       0   88480       0 etop:data_handler/2 
<0.4.0>        erl_prim_loader          '-'       0  121968       0 erl_prim_loader:loop
<0.30.0>       error_logger             '-'       0    8800       0 gen_event:fetch_msg/
<0.31.0>       application_controll     '-'       0  196936       0 gen_server:loop/6   
<0.33.0>       application_master:i     '-'       0    5784       0 application_master:m
========================================================================================

What does this tell me?

Michael



More information about the ejabberd mailing list