[ejabberd] ?= ?==?utf-8?q? Beam consumes > 400% CPU - why

Evgeny Khramtsov xramtsov at gmail.com
Tue Mar 6 09:46:37 MSK 2018


Tue, 6 Mar 2018 05:23:14 +0100
Michael Vogel <icarus at dabo.de> wrote:

> Pid            Name or Initial Func    Time    Reds  Memory    MsgQ
> Current Function
> ----------------------------------------------------------------------------------------
> <6665.512.0>   xmpp_stream_out:init 480616538665794   21552       0
> xmpp:serr_connection
> <6665.521.0>   xmpp_stream_out:init 481966837864000   29472       0
> xmpp_stream_out:hand
> <6665.497.0>   xmpp_stream_out:init 481919735664000   29472       0
> xmpp_stream_out:hand
> <6665.631.0>   inet_tcp_dist:do_acc      22      42    8712       0
> dist_util:con_loop/2
> <6665.45.0>    net_kernel                48      19   18696       0
> gen_server:loop/6
> <6665.489.0>   ejabberd_receiver:in      16      12    1600       0
> erlang:hibernate/3
> <6665.47.0>    net_kernel:ticker/2        9       2    2648       0
> net_kernel:ticker_lo
> <6665.0.0>     init                       0       0    8752       0
> init:loop/1
> <6665.1.0>     erts_code_purger           0       0    2608       0
> erts_code_purger:loo
> <6665.4.0>     erl_prim_loader            0       0  196848       0
> erl_prim_loader:loop
> ========================================================================================

It seems like ejabberd is constantly accepting connections and replying
to them. Don't you see anything suspicious in tcpdump?


More information about the ejabberd mailing list