<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=Windows-1252">
<META NAME="Generator" CONTENT="MS Exchange Server version 6.0.6619.9">
<TITLE>Help installing ejabberd</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/plain format -->

<P><FONT SIZE=2>Hi,<BR>
I'm attempting to install ejabberd 1.1.3 using the provided installer on 64 bit Red Hat AS 4 Rel 3.<BR>
<BR>
The installer is not completing on 1.1.3 (The post-install script is not completing properly).&nbsp; I'm getting the following error:<BR>
<BR>
Error: Error running Post Install Script.<BR>
The installation may have not completed correctly<BR>
<BR>
I checked the logs in /tmp and all the logs say is that the postinstall script didn't finish successfully.<BR>
<BR>
When attempting to run the script manually, I get the following:<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; -=- ejabberd post installation script -=-<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; (c) 2005-2007 Process-one<BR>
<BR>
* Checking ejabberd installation<BR>
<BR>
* Starting ejabberd instance<BR>
* Error, ejabberd can not start<BR>
<BR>
In sasl.log, I get the following:<BR>
<BR>
=SUPERVISOR REPORT==== 7-May-2007::11:54:19 ===<BR>
&nbsp;&nbsp;&nbsp;&nbsp; Supervisor: {local,crypto_sup}<BR>
&nbsp;&nbsp;&nbsp;&nbsp; Context:&nbsp;&nbsp;&nbsp; child_terminated<BR>
&nbsp;&nbsp;&nbsp;&nbsp; Reason:&nbsp;&nbsp;&nbsp;&nbsp; {port_died,normal}<BR>
&nbsp;&nbsp;&nbsp;&nbsp; Offender:&nbsp;&nbsp; [{pid,&lt;0.102.0&gt;},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {name,crypto_server},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {mfa,{crypto_server,start_link,[]}},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {restart_type,permanent},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {shutdown,2000},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {child_type,worker}]<BR>
<BR>
<BR>
=PROGRESS REPORT==== 7-May-2007::11:54:19 ===<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; supervisor: {local,crypto_sup}<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; started: [{pid,&lt;0.120.0&gt;},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {name,crypto_server},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {mfa,{crypto_server,start_link,[]}},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {restart_type,permanent},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {shutdown,2000},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {child_type,worker}]<BR>
<BR>
=CRASH REPORT==== 7-May-2007::11:54:19 ===<BR>
&nbsp; crasher:<BR>
&nbsp;&nbsp;&nbsp; pid: &lt;0.120.0&gt;<BR>
&nbsp;&nbsp;&nbsp; registered_name: crypto_server<BR>
&nbsp;&nbsp;&nbsp; error_info: {port_died,normal}<BR>
&nbsp;&nbsp;&nbsp; initial_call: {gen,init_it,<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [gen_server,<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;0.94.0&gt;,<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;0.94.0&gt;,<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {local,crypto_server},<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; crypto_server,<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [],<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; []]}<BR>
&nbsp;&nbsp;&nbsp; ancestors: [crypto_sup,&lt;0.93.0&gt;]<BR>
&nbsp;&nbsp;&nbsp; messages: []<BR>
&nbsp;&nbsp;&nbsp; links: [&lt;0.94.0&gt;]<BR>
&nbsp;&nbsp;&nbsp; dictionary: []<BR>
&nbsp;&nbsp;&nbsp; trap_exit: true<BR>
&nbsp;&nbsp;&nbsp; status: running<BR>
&nbsp;&nbsp;&nbsp; heap_size: 610<BR>
&nbsp;&nbsp;&nbsp; stack_size: 21<BR>
&nbsp;&nbsp;&nbsp; reductions: 629<BR>
&nbsp; neighbours:<BR>
<BR>
<BR>
<BR>
As far as I can tell, OpenSSL is installed...Is this a known issue?<BR>
<BR>
Please let me know...<BR>
<BR>
Larry<BR>
<BR>
<BR>
<BR>
</FONT>
</P>

</BODY>
</HTML>