<div dir="ltr">i got the same problem way time ago (and i think others as well), here is my blogpost about that:<br><a href="http://www.planeta.toliman.pl/2007/02/mclean.html">http://www.planeta.toliman.pl/2007/02/mclean.html</a><br>
<br>it is in polish, so just copy, edit and compile the program, you must shutdown all nodes, then on every node<br>run program :<br>mclean:clean([&#39;node@name.pl&#39;]). <br><br>it will clean given node, remember to edit patch to schema.DAT file on every node!<br>
<br><br><div class="gmail_quote">On Fri, Sep 26, 2008 at 17:06, Stephan Maihöfer <span dir="ltr">&lt;<a href="mailto:sma@turtle-entertainment.de">sma@turtle-entertainment.de</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">




<div>
<div><span><font size="2" face="Arial">hi,</font></span></div>
<div><span><font size="2" face="Arial"></font></span>&nbsp;</div>
<div><span><font size="2" face="Arial">i have a few 
&quot;inactive nodes&quot; that i would like to remove so i can</font></span></div>
<div><span><font size="2" face="Arial">start over with new 
ones. i tried the remove-node command</font></span></div>
<div><span><font size="2" face="Arial">of ejabebrctl with 
mod_ctlextra and even tried to delete the</font></span></div>
<div><span><font size="2" face="Arial">schema of the nodes 
manually. first yields no result at all, second</font></span></div>
<div><span><font size="2" face="Arial">gives me 
this:</font></span></div>
<div><span><font size="2" face="Arial"></font></span>&nbsp;</div>
<div><span><font size="2" face="Arial">(<a href="mailto:ejabberd@ejabberd1%294" target="_blank">ejabberd@ejabberd1)4</a>&gt; 
mnesia:del_table_copy(schema, <a href="mailto:%27ejabberd@ejabber2%27" target="_blank">&#39;ejabberd@ejabber2&#39;</a>).<br>{aborted,{not_active,&quot;All 
replicas on diskfull nodes are not active 
yet&quot;,<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
schema,<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
[&#39;ejabberd@ejabberd2&#39;]}}<br></font></span></div>
<div><span><font size="2" face="Arial"></font></span>&nbsp;</div>
<div><span><font size="2" face="Arial">in the web-admin all 
the nodes still are being shown as</font></span></div>
<div><span><font size="2" face="Arial">&quot;inactive&quot; and i 
can&#39;t create another node by that name from</font></span></div>
<div><span><font size="2" face="Arial">scratch.</font></span></div>
<div><span><font size="2" face="Arial"></font></span>&nbsp;</div>
<div><span><font size="2" face="Arial">any hints on 
this?</font></span></div>
<div><span><font size="2" face="Arial"></font></span>&nbsp;</div>
<div><span><font size="2" face="Arial">thanks,</font></span></div>
<div><span><font size="2" face="Arial">stephan</font></span></div></div>
<br>_______________________________________________<br>
ejabberd mailing list<br>
<a href="mailto:ejabberd@jabber.ru">ejabberd@jabber.ru</a><br>
<a href="http://lists.jabber.ru/mailman/listinfo/ejabberd" target="_blank">http://lists.jabber.ru/mailman/listinfo/ejabberd</a><br>
<br></blockquote></div><br><br clear="all"><br>-- <br>pozdrawiam,<br>Zbyszek Żółkiewski<br>
</div>