<div class="gmail_quote">On Fri, Mar 6, 2009 at 10:36 AM, Adam <span dir="ltr">&lt;<a href="mailto:adam.bcn@gmail.com">adam.bcn@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
2009/3/5 Lee Azzarello &lt;<a href="mailto:lee@dropio.com">lee@dropio.com</a>&gt;<br>
<div class="im">&gt;<br>
&gt; Google apps -&gt; federation:<br>
&gt; <a href="http://www.google.com/support/a/bin/answer.py?hl=en&amp;answer=34143" target="_blank">http://www.google.com/support/a/bin/answer.py?hl=en&amp;answer=34143</a><br>
&gt;<br>
&gt; You also need SRV records for the domain you are hosting.<br>
&gt;<br>
&gt; -lee<br>
<br>
</div>Ah, SRV records, brilliant!<br>
<br>
Thank you Lee.</blockquote><div><br>This is part of the XMPP core specification . <br><a href="http://xmpp.org/rfcs/rfc3920.html#rfc.section.14.4">http://xmpp.org/rfcs/rfc3920.html#rfc.section.14.4</a> <br><br><br>-- <br>
David Rubin<br>Email : davidrub[ at ]gmail[ dot ]com<br>cell    : +27(0)720405455<br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>

<font color="#888888"><br>
~Adam<br>
</font><div><div></div><div class="h5"><br>
&gt;<br>
&gt; On Thu, Mar 5, 2009 at 1:48 PM, Adam &lt;<a href="mailto:adam.bcn@gmail.com">adam.bcn@gmail.com</a>&gt; wrote:<br>
&gt; &gt; Hello list,<br>
&gt; &gt;<br>
&gt; &gt; this is my first post to <a href="mailto:ejabberd@jabber.ru">ejabberd@jabber.ru</a>, I am an ejabberd newbie and I<br>
&gt; &gt; wondered if someone could help out with the following problem.<br>
&gt; &gt;<br>
&gt; &gt; I have set up an ejabberd on a XEN VPS host. I am able to start/stop the<br>
&gt; &gt; server and log in, and chat between different users on the same host. So far<br>
&gt; &gt; so good.<br>
&gt; &gt;<br>
&gt; &gt; Unfortunately I seem to be unable to get my jabber to server to talk to<br>
&gt; &gt; other jabber servers. For example, I logged in to a <a href="http://talk.google.com" target="_blank">talk.google.com</a> account<br>
&gt; &gt; (user A), and added a user on my ejabberd server as a contact (user B).<br>
&gt; &gt; User B recieves no notification of the request, and appears in users A&#39;s<br>
&gt; &gt; list as offline.  Adding user A as a contact for user B, I get the message<br>
&gt; &gt; &#39;404 remote server not found&#39;. (I should add that I&#39;m trying this out with<br>
&gt; &gt; the Pidgin client).  My server seems to be listening on port 5269; I tried<br>
&gt; &gt; this from my laptop:<br>
&gt; &gt;<br>
&gt; &gt;   echo &quot;Hello&quot; | nc <a href="http://li51-176.members.linode.com" target="_blank">li51-176.members.linode.com</a> 5269<br>
&gt; &gt;   &lt;?xml version=&#39;1.0&#39;?&gt;&lt;stream:stream ..... etc<br>
&gt; &gt;<br>
&gt; &gt; My ejabberd.cfg is here:<br>
&gt; &gt; <a href="http://li51-176.members.linode.com/ejabberd.cfg" target="_blank">http://li51-176.members.linode.com/ejabberd.cfg</a><br>
&gt; &gt;<br>
&gt; &gt; Could anybody provide any pointers as to what I might be doing wrong?<br>
&gt; &gt;<br>
&gt; &gt; Kind regards,<br>
&gt; &gt;<br>
&gt; &gt; ~Adam<br>
_______________________________________________<br>
ejabberd mailing list<br>
<a href="mailto:ejabberd@jabber.ru">ejabberd@jabber.ru</a><br>
<a href="http://lists.jabber.ru/mailman/listinfo/ejabberd" target="_blank">http://lists.jabber.ru/mailman/listinfo/ejabberd</a><br>
</div></div></blockquote></div><br><br clear="all"><br>