<br>i looked at the url but still a bit confused... it says you get this error when trying to start another instance of ejabberd, but i am not starting another instance of ejabberd, just trying to register a user..<br><br>
-- yan<br><br><div class="gmail_quote">On Fri, Sep 18, 2009 at 3:55 AM, Konstantin Khomoutov <span dir="ltr">&lt;<a href="mailto:flatworm@users.sourceforge.net">flatworm@users.sourceforge.net</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Jan Koum wrote:<br>
<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="im">
17/Sep/2009:15:27:36 HARDFAIL command:<br>
[/home/jkoum/ejabberd-2.1.0_beta1/bin/ejabberdctl register xxx<br></div>
s.example.netyyy] return: 1<div class="im"><br>
{error_logger,{{2009,9,17},{15,27,33}},&quot;Protocol: ~p:<br>
register error:<br>
~p~n&quot;,[&quot;inet_tcp&quot;,{{badmatch,{error,duplicate_name}},[{inet_tcp_dist,listen,1},{net_kernel,start_protos,4},{net_kernel,start_protos,3},{net_kernel,init_node,2},{net_kernel,init,1},{gen_server,init_it,6},{proc_lib,init_p,5}]}]}<br>

<br>
while end result is the same, i am curious if this different behavior is<br>
normal or is this some bug we are triggering?<br>
</div></blockquote>
This error has nothing to do with user registration,<br>
at least not directly. See [1] for explanations.<br>
<br>
1. <a href="http://www.ejabberd.im/error/duplicate_name" target="_blank">http://www.ejabberd.im/error/duplicate_name</a><br>
<br>
_______________________________________________<br>
ejabberd mailing list<br>
<a href="mailto:ejabberd@jabber.ru" target="_blank">ejabberd@jabber.ru</a><br>
<a href="http://lists.jabber.ru/mailman/listinfo/ejabberd" target="_blank">http://lists.jabber.ru/mailman/listinfo/ejabberd</a><br>
</blockquote></div><br>