Sounds like two issues...<div><br></div><div>Issue 1, google talk from what I remember doesn&#39;t like routing stanzas to any jid which isn&#39;t in your contacts, so that can be a problem (although testing has previously shown that this is not ALWAYS the case, sometimes it is perfectly happy).</div>
<div><br></div><div>Issue 2, why are you trying to run the mod_echo on the main domain of the server (<a href="http://mydomain.com">mydomain.com</a>) ? as it is a component it would make more sense to run it on something like <a href="http://echo.mydomain.com">echo.mydomain.com</a>, so your message would get sent to <a href="mailto:test@echo.mydomain.com">test@echo.mydomain.com</a></div>
<div><br></div><div>Just my thoughts.</div><div><br></div><div>Cheers</div><div><br></div><div>Kirk</div><div><br><br><div class="gmail_quote">On 16 February 2010 14:57, Conor Hunt <span dir="ltr">&lt;<a href="mailto:conor.hunt%2Bejabberd@gmail.com">conor.hunt+ejabberd@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">I&#39;m trying to use the mod_echo module on my server, like this:<br>
<br>
{loglevel, 4}.<br>
{hosts, [&quot;<a href="http://mydomain.com" target="_blank">mydomain.com</a>&quot;]}.<br>
{listen,<br>
 [<br>
  {5269, ejabberd_s2s_in, [<br>
    {shaper, s2s_shaper},<br>
    {max_stanza_size, 131072}<br>
]}<br>
{s2s_default_policy, allow}.<br>
{shaper, fast, {maxrate, 50000}}.<br>
{access, s2s_shaper, [{fast, all}]}.<br>
{modules,<br>
 [<br>
  {mod_echo, [{host, &quot;<a href="http://mydomain.com" target="_blank">mydomain.com</a>&quot;}]}<br>
 ]}.<br>
<br>
I then send a message to <a href="mailto:test@mydomain.com">test@mydomain.com</a> from google talk and it works fine<br>
about 50% of the time. I get the message echoed back. The other 50% of the time<br>
it fails to route the message to mod_echo. Here is the log of that at level 5:<br>
<br>
<a href="http://gist.github.com/305568" target="_blank">http://gist.github.com/305568</a><br>
<br>
Anyone able to tell me what I am doing wrong?<br>
<br>
Thanks.<br>
<br>
_______________________________________________<br>
ejabberd mailing list<br>
<a href="mailto:ejabberd@jabber.ru">ejabberd@jabber.ru</a><br>
<a href="http://lists.jabber.ru/mailman/listinfo/ejabberd" target="_blank">http://lists.jabber.ru/mailman/listinfo/ejabberd</a><br>
</blockquote></div><br></div>