<div class="gmail_quote"><br>I want to setup Ejabberd chat server for private network. I have intranet and i am running ejabberd server in one of the server in private network. I have configured it to work perfectly on local network but now i want to extend its functionality to be able to chat with gmail, facebook, <a href="http://jabber.org" target="_blank">jabber.org</a> and other friends. I started to make it work with <a href="http://jabber.org" target="_blank">jabber.org</a> first. When i add some new friend <a href="mailto:somefriend@jabber.org" target="_blank">somefriend@jabber.org</a> to my private network jabber id and tries to debug, it says<b>Received XML on stream = " "</b>.<div>



<br></div><div>I am using {loglevel, 5}. and<b>netstat -taupen | grep 5269</b> shows a ESTABLISHED connection with<a href="http://208.68.163.220:5269" target="_blank">208.68.163.220:5269</a> which is indeed IP address of <a href="http://jabber.org" target="_blank">jabber.org</a>. So the connection with <a href="http://jabber.org" target="_blank">jabber.org</a> is established but i am not getting any response from the remote server.</div>



<div><br></div><div><br></div><div>Here is my ejabberd.cfg :<a href="http://pastebin.com/AXyCj9e3" target="_blank">http://pastebin.com/AXyCj9e3</a></div><div><div><div><br></div><div>Here is relevant entries in ejabberd.log :<a href="http://pastebin.com/ruZj38Uv">http://pastebin.com/ruZj38Uv</a></div>

<meta http-equiv="content-type" content="text/html; charset=utf-8"><div>
<div><div><br clear="all"><br>-- <br><div><span style="border-collapse:collapse;color:rgb(136, 136, 136);font-family:arial, sans-serif;font-size:13px"><div>Aamir Khan<br></div></span></div></div></div></div></div></div></div>