[Tkabber] uri 1.1 error

Marshall Rose mrose@dbc.mtview.ca.us
Thu, 19 Dec 2002 15:24:16 -0800


> when i try run Tkabber it give me error
> 
> Error in startup script: can't find package uri 1.1
>     while executing
> "package require uri 1.1"
>     (file "./jabberlib-tclxml/tclxml/sgmlparser.tcl" line 39)
>     invoked from within
> "splash_source ./jabberlib-tclxml/tclxml/sgmlparser.tcl"
> 
> and crashes

to run tkabber you need to have installed tcllib 1.2 or later.
    
    http://sourceforge.net/project/showfiles.php?group_id=12883
    
this contains the uri package.
    
so, if you're seeing this error, then you don't have tcllib 1.2 (or
later) installed where tcl can find it.
    
on my system, it got installed in
    
    /usr/pkg/lib/tcl/tcllib1.3/
    
on your system, it may be something like
    
    /usr/pkg/lib/tcl8.3/tcllib1.3/
    
you can find out what tcl knows by doing this:
    
    % tclsh
    tclsh> package requires uri 1.1
    
if you get back an error, then do this
    
    tclsh> set auto_path

which on my system prints this:
    
    /usr/pkg/lib/tcl8.3 /usr/pkg/lib/tcl
    
this tells me that i need to install tcllib somewhere under one of these
three directories...
    
/mtr